Форум   Статьи   Новости   Файлы   Bugtraq   Сниффер   Друзья   О Клубе
  , 12:59   #1
Banned
 
Локация: Соединенные Штаты Казахстана
Регистрация: 30.04.2010
Сообщений: 312

Репутация: 20 / 0
Arrow Базовая настройка межсетевого экрана Cisco ASA 5510

Cisco ASA 5510 Security Appliance - межсетевой экран Cisco, который является достаточно популярным среди всей линейки ASA 5500, поскольку он предназначен и применяется для обеспечения безопасности на предприятиях малого и среднего бизнеса. Как и ее младшая модель ASA 5505, 5510 можно заказать как с базовой лицензий (Base license), так и с лицензией Security Plus. Лицензия Security Plus открывает дополнительные возможности производительности ASA по сравнению с базовой лицензией, такие как брандмауэр на 130.000 максимальных соединений (вместо 50.000), максимальное количество VLAN увеличено до 100 (вместо 50), расширенные возможности обеспечения отказоустойчивости и т.д. Кроме того, лицензия Security Plus позволяет двум из пяти портов ASA работать на скорости 10/100/1000Мбит/с, а не только 10/100Мбит/с.

Если вы уже приобрели лицензию, то активировать ее можно выполнив следующие команды:
code:
telecombookASA(config)#activation-key 0xab12cd34
telecombookASA(config)#exit
telecombookASA#copy running startup
telecombookASA#reload
Далее представлен простой сценарий доступа к сети Интернет, где Интернет-провайдер предоставил нам внешний статический IP адрес 77.77.77.1, внутренняя сеть использует следующее адресное пространство: 172.16.10.0/24. Будем использовать интерфейс Ethernet0/0 для WAN. Физический интерфейс Ethernet0/1 будет использован для подключения всех внутренних сетевых устройств. Логически, все внутренние устройства сети будут находиться в VLAN 10, отсюда задействуем логический интерфейс Ethernet0/1.10. Настроим ASA так, чтобы она автоматически выдавала IP адреса рабочим станциям по протоколу DHCP. Настроим NAT(PAT) в направлении внутренняя сеть – внешняя сеть.

Топология сети представлена ниже:
IMAGE http://www.telecombook.ru/cisco/articles/images/basicasa.jpg

Прежде всего, необходимо настроить пароль для доступа к ASA в режиме глобальной конфигурации командой enable password MyPass, где MyPass - пароль к устройству:
code:
telecombookASA(config)#enable password MyPass
Для настройки внешнего интерфейса, необходимо набрать команду interface Ethernet0/0, задать имя командой nameif outside, уровень безопасности security-level 0 и IP адрес ip address 77.77.77.1 255.255.255.252.
code:
telecombookASA(config)#interface Ethernet0/0
telecombookASA(config-if)#nameif outside
telecombookASA(config-if)#security-level 0
telecombookASA(config-if)#ip address 77.77.77.1 255.255.255.252
telecombookASA(config-if)#no shut
Настроим внутренний интерфейс Ethernet0/1.10 и поместим его в транк 802.1q для VLAN 10. Пример:
code:
telecombookASA(config)#interface Ethernet0/1
telecombookASA(config-if)#speed 100
telecombookASA(config-if)#duplex full
telecombookASA(config-if)#no nameif
telecombookASA(config-if)#no security-level
telecombookASA(config-if)#no ip address
telecombookASA(config-if)#no shut

telecombookASA(config)#interface Ethernet0/1.10
telecombookASA(config-if)#nameif inside
telecombookASA(config-if)#vlan 10
telecombookASA(config-if)#security-level 100
telecombookASA(config-if)#ip address 172.16.10.254 255.255.255.0
telecombookASA(config-if)#no shut
Настроим PAT:
code:
telecombookASA(config)#global (outside) 1 interface
telecombookASA(config)#nat (inside) 1 172.16.0.0 255.255.0.0
Настроим маршрут по умолчанию:
code:
telecombookASA(config)#route outside 0.0.0.0 0.0.0.0 77.77.77.2 1

!*1 – административная дистанция.
Настроим DHCP сервер на ASA:
code:
telecombookASA(config)#dhcpd dns 88.88.88.20
telecombookASA(config)#dhcpd address 172.16.10.1-192.168.10.240 inside
telecombookASA(config)#dhcpd enable inside
Полный конфиг будет выглядеть так:
code:
telecombookASA(config)#enable password MyPass

telecombookASA(config)#interface Ethernet0/0
telecombookASA(config-if)#nameif outside
telecombookASA(config-if)#security-level 0
telecombookASA(config-if)#ip address 77.77.77.1 255.255.255.252
telecombookASA(config-if)#no shut

telecombookASA(config)#interface Ethernet0/1
telecombookASA(config-if)#speed 100
telecombookASA(config-if)#duplex full
telecombookASA(config-if)#no nameif
telecombookASA(config-if)#no security-level
telecombookASA(config-if)#no ip address
telecombookASA(config-if)#no shut

telecombookASA(config)#interface Ethernet0/1.10
telecombookASA(config-if)#nameif inside
telecombookASA(config-if)#vlan 10
telecombookASA(config-if)#security-level 100
telecombookASA(config-if)#ip address 172.16.10.254 255.255.255.0
telecombookASA(config-if)#no shut

telecombookASA(config)#global (outside) 1 interface
telecombookASA(config)#nat (inside) 1 172.16.0.0 255.255.0.0

telecombookASA(config)#route outside 0.0.0.0 0.0.0.0 77.77.77.2 1

telecombookASA(config)#dhcpd dns 88.88.88.20
telecombookASA(config)#dhcpd address 172.16.10.1-192.168.10.240 inside
telecombookASA(config)#dhcpd enable inside


Источник: http://www.telecombook.ru
 

Последний раз редактировалось soldat_123; 07.09.2011 в 13:21.
Пользователь вне форума    
Наши Спонсоры
 

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Traffic Policing на межсетевом экране Cisco ASA soldat_123 Cisco 0 07.09.2011 13:07
Настройка NAT на межсетевом экране Cisco ASA soldat_123 Cisco 0 07.09.2011 13:06



Часовой пояс GMT +2
Powered by vBulletin® 3.x.x Copyright ©2000 - 2012, Jelsoft Enterprises Ltd.

Copyright © 2008 - 2013 «HPC» Реклама на сайте Правила Форума Пользовательское соглашение Работа на сайте
При копировании материалов ставьте ссылку на источник
Все материалы представлены только в ознакомительных целях, администрация за их использование ответственности не несет.